Linux Preview

Hace 10 meses

Canonical lanza actualización de seguridad de Kernel Live Patch para Ubuntu 16.04 LTS

kernel live patch security


El 30 de noviembre de 2016, después de publicar nuevas actualizaciones del kernel para todas sus versiones de Ubuntu Linux, Canonical, a través de Luis Henriques, anunció la disponibilidad de la segunda actualización de seguridad de kernel live patch para Ubuntu 16.04 LTS.

Si está utilizando el servicio Canonical Livepatch en su máquina 64 bits Ubuntu 16.04 LTS (Xenial Xerus), ahora puede descargar los paquetes del kernel utilizando esta tecnología de reinicio. La última actualización corrige un total de cuatro vulnerabilidades del kernel descubiertas recientemente por varios hackers e investigadores de seguridad.

El primer problema de seguridad, CVE-2016-7042, fue descubierto por Ondrej Kozina en la interfaz de keyring del kernel de Linux como un desbordamiento de búfer que podría aparecer al mostrar eventos de tiempo de espera a través de la interfaz /proc/keys, permitiendo a un atacante local bloquear el sistema afectado.

La segunda vulnerabilidad, documentada como CVE-2016-7117, fue descubierta por Dmitry Vyukov en la implementación recvmmsg del kernel de Linux durante el procesamiento de errores, lo que podría haber permitido a un atacante remoto bloquear el sistema o ejecutar código arbitrario.

La tercera falla de seguridad, CVE-2016-7425, fue descubierta por Marco Grassi en el controlador de kernel de Linux para los Controladores RAID de Areca, que no validó correctamente los mensajes de control, permitiendo así a un atacante local obtener privilegios administrativos o bloquear el sistema vulnerable.

El último problema de seguridad (CVE-2016-8658) remendado en esta actualización fue un desbordamiento de búfer basado en pila descubierto por Daxing Guo en el controlador Broadcom IEEE802.11n FullMAC del kernel de Linux, lo que podría haber permitido a un atacante local causar una denegación de servicio o Obtener privilegios administrativos.

“Ubuntu 16.04 LTS usuarios con Canonical Livepatch Service necesidad de actualizar ahora”

Canonical recomienda a todos los usuarios de Ubuntu 16.04 LTS (Xenial Xerus) que utilicen el servicio Canonical Livepatch para actualizar sus sistemas lo antes posible. Los problemas de seguridad mencionados anteriormente se pueden actualizar actualizando sus livepatches a la versión 4.4.0-21.37 del kernel, que está disponible en variantes genéricas y lowlatency.

Más información en: softpedia.com





Comentar con Facebook